Since the documentation to install Oracle Database on the Solaris SPARC 64bit is so lame, I wrote the short step-by-step instruction on how to install the database, using response file.
I assume, that the network is configured and all appropriate packages are installed, so let’s start with configuring project and kernel parameter for user oracle:
# groupadd dba # groupadd oinstall # useradd -m -g oinstall -G dba oracle # projadd user.oracle
We will use values for the appropriate parameters from documentation:
http://docs.oracle.com/database/121/SSDQI/toc.htm#BABDAGHH
# projmod -s -K "project.max-sem-ids=(privileged,100,deny)" user.oracle # projmod -s -K "process.max-sem-nsems=(privileged,256,deny)" user.oracle # projmod -s -K "project.max-shm-memory=(privileged,10g,deny)" user.oracle # projmod -s -K "project.max-shm-ids=(privileged,100,deny)" user.oracle # projmod -s -K "process.max-file-descriptor=(privileged,65536,deny)" user.oracle # projects -l user.oracle user.oracle projid : 100 comment: "" users : (none) groups : (none) attribs: process.max-file-descriptor=(privileged,65536,deny) process.max-sem-nsems=(privileged,256,deny) project.max-sem-ids=(privileged,100,deny) project.max-shm-ids=(privileged,100,deny) project.max-shm-memory=(privileged,10737418240,deny) # ipadm set-prop -p smallest_anon_port=9000 tcp # ipadm set-prop -p largest_anon_port=65500 tcp # ipadm set-prop -p smallest_anon_port=9000 udp # ipadm set-prop -p largest_anon_port=65500 udp # ipadm show-prop tcp PROTO PROPERTY PERM CURRENT PERSISTENT DEFAULT POSSIBLE tcp cong_default rw newreno -- newreno newreno,cubic, highspeed,vegas tcp cong_enabled rw newreno,cubic, newreno,cubic, newreno newreno,cubic, highspeed, highspeed, highspeed,vegas vegas vegas tcp ecn rw passive -- passive never,passive, active tcp extra_priv_ports rw 2049,4045 -- 2049,4045 1-65535 tcp largest_anon_port rw 65500 65500 65535 9000-65535 tcp max_buf rw 1048576 -- 1048576 128000-1073741824 tcp recv_buf rw 128000 -- 128000 2048-1048576 tcp sack rw active -- active never,passive, active tcp send_buf rw 49152 -- 49152 4096-1048576 tcp smallest_anon_port rw 9000 9000 32768 1024-65500 tcp smallest_nonpriv_port rw 1024 -- 1024 1024-32768 # ipadm show-prop udp PROTO PROPERTY PERM CURRENT PERSISTENT DEFAULT POSSIBLE udp extra_priv_ports rw 2049,4045 -- 2049,4045 1-65535 udp largest_anon_port rw 65500 65500 65535 9000-65535 udp max_buf rw 2097152 -- 2097152 65536-1073741824 udp recv_buf rw 57344 -- 57344 128-2097152 udp send_buf rw 57344 -- 57344 1024-2097152 udp smallest_anon_port rw 9000 9000 32768 1024-65500 udp smallest_nonpriv_port rw 1024 -- 1024 1024-32768
To meet all the requirements we will set the amount of SWAP to same value as RAM:
# prtconf | grep Memory Memory size: 16384 Megabytes # zfs set volsize=16G rpool/swap # zfs list | grep swap rpool/swap 16.5G 43.7G 16.0G -
We will install software only and use the dbca to create a database.
For installing software only version you have to alter only those lines in the response file:
oracle.install.option=INSTALL_DB_SWONLY ORACLE_HOSTNAME=oradb UNIX_GROUP_NAME=oinstall INVENTORY_LOCATION=/u01/app/oraInventory ORACLE_HOME=/u01/app/oracle/product/11.2.0.4/dbhome_1 ORACLE_BASE=/u01/app/oracle oracle.install.db.InstallEdition=SE oracle.install.db.DBA_GROUP=dba DECLINE_SECURITY_UPDATES=true oracle.installer.autoupdates.option=SKIP_UPDATES
The installation command looks like this:
$ ./runInstaller -silent -showProgress -responseFile /export/home/oracle/database/db_install.rsp oracle@oradb:~/database$ ./runInstaller -silent -showProgress -responseFile /export/home/oracle/database/db_install.rsp Starting Oracle Universal Installer... Checking Temp space: must be greater than 180 MB. Actual 20498 MB Passed Checking swap space: must be greater than 150 MB. Actual 21656 MB Passed Preparing to launch Oracle Universal Installer from /tmp/OraInstall2015-03-12_09-35-18PM. Please wait ... $ ps aux |[WARNING] [INS-13014] Target environment do not meet some optional requirements. CAUSE: Some of the optional prerequisites are not met. See logs for details. /u01/app/oraInventory/logs/installActions2015-03-12_09-35-18PM.log ACTION: Identify the list of failed prerequisite checks from the log: /u01/app/oraInventory/logs/installActions2015-03-12_09-35-18PM.log. Then either from the log file or from installation manual find the appropriate configuration to meet the prerequisites and fix it manually. You can find the log of this install session at: /u01/app/oraInventory/logs/installActions2015-03-12_09-35-18PM.log Prepare in progress. .................................................. 9% Done. Prepare successful. Copy files in progress. .................................................. 15% Done. .................................................. 21% Done. .................................................. 27% Done. .................................................. 32% Done. .................................................. 37% Done. .................................................. 42% Done. .................................................. 47% Done. .................................................. 53% Done. .................................................. 58% Done. .................................................. 63% Done. .................................................. 68% Done. .................................................. 73% Done. .................................................. 78% Done. .................................................. 83% Done. .............................. Copy files successful. Link binaries in progress. .......... Link binaries successful. Setup files in progress. .................................................. 88% Done. .................................................. 94% Done. Setup files successful. The installation of Oracle Database 11g was successful. Please check '/u01/app/oraInventory/logs/silentInstall2015-03-12_09-35-18PM.log' for more details. Execute Root Scripts in progress. As a root user, execute the following script(s): 1. /u01/app/oracle/product/11.2.0.4/dbhome_1/root.sh .................................................. 100% Done. Execute Root Scripts successful. Successfully Setup Software.
Now let’s create the database with dbca:
dbca -silent -createDatabase -templateName General_Purpose.dbc -gdbName orcl -sid orcl -sysPassword Dupa123 -systemPassword Dupa123 -emConfiguration LOCAL -dbsnmpPassword Dupa123 -sysmanPassword Dupa123 -datafileDestination /u01/app/oracle/oradata -storageType FS -characterSet EE8MSWIN1250 -nationalCharacterSet AL16UTF16 -automaticMemoryManagement false -totalMemory 4096 -databaseType MULTIPURPOSE sh: line 1: showrev: not found sh: line 1: showrev: not found Copying database files 1% complete 3% complete 11% complete 18% complete 26% complete 37% complete Creating and starting Oracle instance 40% complete 45% complete 50% complete 55% complete 56% complete 60% complete 62% complete Completing Database Creation 66% complete 70% complete 73% complete 85% complete 96% complete 100% complete Look at the log file "/u01/app/oracle/cfgtoollogs/dbca/orcl/orcl.log" for further details.